All systems operational

Collaborative documents periodically fail to load

Resolved
Partial outage
Started 9 months ago Lasted 20 minutes

Affected

EU
Collaborative Documents
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this incident.