Resolved🚨 Fibery is down for all customers
Started
September 05, 2023 at 13:30
Status
Resolved after about 1 hour
Impact
Major outage
Affected
EU
API
Live Updates
Search
Collaborative Documents
Automations
Application
Integrations
- Resolved
- Investigating