All systems operational

Resolved
Collaborative Documents partial outage

Started
December 20, 2023 at 14:23
Status
Resolved after 24 minutes

Impact

Partial outage
Affected
EU
Collaborative Documents
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this incident.